summaryrefslogtreecommitdiffstats
path: root/src/platformsupport/graphics/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/platformsupport/graphics/CMakeLists.txt')
-rw-r--r--src/platformsupport/graphics/CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/src/platformsupport/graphics/CMakeLists.txt b/src/platformsupport/graphics/CMakeLists.txt
index cbb9e0937b..e9f0245dbe 100644
--- a/src/platformsupport/graphics/CMakeLists.txt
+++ b/src/platformsupport/graphics/CMakeLists.txt
@@ -11,12 +11,9 @@ qt_add_module(GraphicsSupport
qrasterbackingstore.cpp qrasterbackingstore_p.h
DEFINES
QT_NO_CAST_FROM_ASCII
- LIBRARIES
+ PUBLIC_LIBRARIES
Qt::CorePrivate
Qt::GuiPrivate
- PUBLIC_LIBRARIES
- Qt::Core
- Qt::Gui
)
#### Keys ignored in scope 1:.:.:graphics.pro:<TRUE>:
83; font-style:italic">** accordance with the commercial license agreement provided with the ** Software or, alternatively, in accordance with the terms contained in ** a written agreement between you and The Qt Company. For licensing terms ** and conditions see https://www.qt.io/terms-conditions. For further ** information use the contact form at https://www.qt.io/contact-us. ** ** BSD License Usage ** Alternatively, you may use this file under the terms of the BSD license ** as follows: ** ** "Redistribution and use in source and binary forms, with or without ** modification, are permitted provided that the following conditions are ** met: ** * Redistributions of source code must retain the above copyright ** notice, this list of conditions and the following disclaimer. ** * Redistributions in binary form must reproduce the above copyright ** notice, this list of conditions and the following disclaimer in ** the documentation and/or other materials provided with the ** distribution. ** * Neither the name of The Qt Company Ltd nor the names of its ** contributors may be used to endorse or promote products derived ** from this software without specific prior written permission. ** ** ** THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS ** "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT ** LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR ** A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT ** OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, ** SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT ** LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, ** DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY ** THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT ** (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE ** OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE." ** ** $QT_END_LICENSE$ ** ****************************************************************************/ #include "mqttdataproviderpool.h" #include "mqttdataprovider.h" #include <QtCore/QDebug> MqttDataProviderPool::MqttDataProviderPool(QObject *parent) : DataProviderPool(parent) , m_client(new QMqttClient(this)) { m_poolName = "Mqtt"; } void MqttDataProviderPool::startScanning() { emit providerConnected("MQTT_CLOUD"); emit providersUpdated(); emit dataProvidersChanged(); m_client->setHostname(QLatin1String(MQTT_BROKER)); m_client->setPort(MQTT_PORT); m_client->setUsername(QByteArray(MQTT_USERNAME)); m_client->setPassword(QByteArray(MQTT_PASSWORD)); connect(m_client, &QMqttClient::connected, [this]() { auto sub = m_client->subscribe(QLatin1String("sensors/active")); connect(sub, &QMqttSubscription::messageReceived, this, &MqttDataProviderPool::deviceUpdate); }); connect(m_client, &QMqttClient::disconnected, [this]() { qDebug() << "Pool client disconnected"; }); m_client->connectToHost(); } void MqttDataProviderPool::deviceUpdate(const QMqttMessage &msg) { static QSet<QString> knownDevices; // Registration is: deviceName>Online const QByteArrayList payload = msg.payload().split('>'); const QString deviceName = payload.first(); const QString deviceStatus = payload.at(1); const QString subName = QString::fromLocal8Bit("sensors/%1/#").arg(deviceName); bool updateRequired = false; if (deviceStatus == QLatin1String("Online")) { // new device // Skip local items if (deviceName.startsWith(QSysInfo::machineHostName())) return; if (!knownDevices.contains(deviceName)) { auto prov = new MqttDataProvider(deviceName, m_client, this); prov->setState(SensorTagDataProvider::Connected); m_dataProviders.push_back(prov); if (m_currentProvider == nullptr) setCurrentProviderIndex(m_dataProviders.size() - 1); knownDevices.insert(deviceName); updateRequired = true; } } else if (deviceStatus == QLatin1String("Offline")) { // device died knownDevices.remove(deviceName); updateRequired = true; for (auto prov : m_dataProviders) { if (prov->id() == deviceName) { m_dataProviders.removeAll(prov); break; } } } if (updateRequired) { emit providersUpdated(); emit dataProvidersChanged(); } }