summaryrefslogtreecommitdiffstats
path: root/src/platformsupport/input/xkbcommon/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/platformsupport/input/xkbcommon/CMakeLists.txt')
-rw-r--r--src/platformsupport/input/xkbcommon/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/platformsupport/input/xkbcommon/CMakeLists.txt b/src/platformsupport/input/xkbcommon/CMakeLists.txt
new file mode 100644
index 0000000000..1a96d5eafe
--- /dev/null
+++ b/src/platformsupport/input/xkbcommon/CMakeLists.txt
@@ -0,0 +1,36 @@
+# Generated from xkbcommon.pro.
+
+#####################################################################
+## XkbCommonSupport Module:
+#####################################################################
+
+add_qt_module(XkbCommonSupport
+ STATIC
+ INTERNAL_MODULE
+ SOURCES
+ qxkbcommon.cpp qxkbcommon_p.h
+ qxkbcommon_3rdparty.cpp
+ DEFINES
+ QT_NO_CAST_FROM_ASCII
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ XKB::XKB
+)
+
+#### Keys ignored in scope 1:.:.:xkbcommon.pro:<TRUE>:
+# CONFIG = "static" "internal_module"
+# MODULE = "xkbcommon_support"
+# PRECOMPILED_HEADER = "../../../corelib/global/qt_pch.h"
+# _LOADED = "qt_module"
+
+## Scopes:
+#####################################################################
+
+extend_target(XkbCommonSupport CONDITION CLANG AND NOT ICC
+ COMPILE_OPTIONS
+ -ftemplate-depth=1024
+)