summaryrefslogtreecommitdiffstats
path: root/src/plugins/bearer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/bearer/CMakeLists.txt')
-rw-r--r--src/plugins/bearer/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/src/plugins/bearer/CMakeLists.txt b/src/plugins/bearer/CMakeLists.txt
index ec860de2cb..88e4f4206e 100644
--- a/src/plugins/bearer/CMakeLists.txt
+++ b/src/plugins/bearer/CMakeLists.txt
@@ -1,9 +1,11 @@
-if (NOT ANDROID AND LINUX AND QT_FEATURE_dbus)
+# Generated from bearer.pro.
+
+if(NOT ANDROID AND LINUX AND TARGET Qt::DBus) # special case
add_subdirectory(generic)
add_subdirectory(connman)
add_subdirectory(networkmanager)
-elseif(ANDROID AND NOT ANDROID_EMBEDDED)
-# TODO add_subdirectory(android)
-else()
+else if(ANDROID AND NOT ANDROID_EMBEDDED) # special case
+ add_subdirectory(android)
+else() # special case
add_subdirectory(generic)
endif()