summaryrefslogtreecommitdiffstats
path: root/src/plugins/generic/evdevtouch/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/generic/evdevtouch/CMakeLists.txt')
-rw-r--r--src/plugins/generic/evdevtouch/CMakeLists.txt15
1 files changed, 6 insertions, 9 deletions
diff --git a/src/plugins/generic/evdevtouch/CMakeLists.txt b/src/plugins/generic/evdevtouch/CMakeLists.txt
index ae0ec4ae4b..e4a4d40c2a 100644
--- a/src/plugins/generic/evdevtouch/CMakeLists.txt
+++ b/src/plugins/generic/evdevtouch/CMakeLists.txt
@@ -1,25 +1,22 @@
# Generated from evdevtouch.pro.
#####################################################################
-## qevdevtouchplugin Plugin:
+## QEvdevTouchScreenPlugin Plugin:
#####################################################################
-add_qt_plugin(qevdevtouchplugin
+qt_add_plugin(QEvdevTouchScreenPlugin
+ OUTPUT_NAME qevdevtouchplugin
TYPE generic
- CLASS_NAME QEvdevTouchScreenPlugin
SOURCES
main.cpp
- LIBRARIES
- Qt::CorePrivate
- Qt::GuiPrivate
- Qt::InputSupportPrivate
PUBLIC_LIBRARIES
Qt::Core
+ Qt::CorePrivate
Qt::Gui
- Qt::InputSupport
+ Qt::GuiPrivate
+ Qt::InputSupportPrivate
)
#### Keys ignored in scope 1:.:.:evdevtouch.pro:<TRUE>:
# OTHER_FILES = "evdevtouch.json"
# PLUGIN_EXTENDS = "-"
-# _LOADED = "qt_plugin"