summaryrefslogtreecommitdiffstats
path: root/src/plugins/generic/libinput/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/generic/libinput/CMakeLists.txt')
-rw-r--r--src/plugins/generic/libinput/CMakeLists.txt15
1 files changed, 6 insertions, 9 deletions
diff --git a/src/plugins/generic/libinput/CMakeLists.txt b/src/plugins/generic/libinput/CMakeLists.txt
index f44265c4d6..b772623307 100644
--- a/src/plugins/generic/libinput/CMakeLists.txt
+++ b/src/plugins/generic/libinput/CMakeLists.txt
@@ -1,25 +1,22 @@
# Generated from libinput.pro.
#####################################################################
-## qlibinputplugin Plugin:
+## QLibInputPlugin Plugin:
#####################################################################
-add_qt_plugin(qlibinputplugin
+qt_add_plugin(QLibInputPlugin
+ OUTPUT_NAME qlibinputplugin
TYPE generic
- CLASS_NAME QLibInputPlugin
SOURCES
main.cpp
- LIBRARIES
- Qt::CorePrivate
- Qt::GuiPrivate
- Qt::InputSupportPrivate
PUBLIC_LIBRARIES
Qt::Core
+ Qt::CorePrivate
Qt::Gui
- Qt::InputSupport
+ Qt::GuiPrivate
+ Qt::InputSupportPrivate
)
#### Keys ignored in scope 1:.:.:libinput.pro:<TRUE>:
# OTHER_FILES = "libinput.json"
# PLUGIN_EXTENDS = "-"
-# _LOADED = "qt_plugin"