summaryrefslogtreecommitdiffstats
path: root/src/plugins/imageformats/jpeg/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/imageformats/jpeg/CMakeLists.txt')
-rw-r--r--src/plugins/imageformats/jpeg/CMakeLists.txt12
1 files changed, 5 insertions, 7 deletions
diff --git a/src/plugins/imageformats/jpeg/CMakeLists.txt b/src/plugins/imageformats/jpeg/CMakeLists.txt
index 065ac08af6..6aaa6538ec 100644
--- a/src/plugins/imageformats/jpeg/CMakeLists.txt
+++ b/src/plugins/imageformats/jpeg/CMakeLists.txt
@@ -3,24 +3,22 @@
qt_find_package(JPEG) # special case
#####################################################################
-## qjpeg Plugin:
+## QJpegPlugin Plugin:
#####################################################################
-add_qt_plugin(qjpeg
+qt_add_plugin(QJpegPlugin
+ OUTPUT_NAME qjpeg
TYPE imageformats
- CLASS_NAME QJpegPlugin
SOURCES
main.cpp main.h
qjpeghandler.cpp qjpeghandler_p.h
- LIBRARIES
- Qt::CorePrivate
- Qt::GuiPrivate
PUBLIC_LIBRARIES
JPEG::JPEG
Qt::Core
+ Qt::CorePrivate
Qt::Gui
+ Qt::GuiPrivate
)
#### Keys ignored in scope 1:.:.:jpeg.pro:<TRUE>:
# OTHER_FILES = "jpeg.json"
-# _LOADED = "qt_plugin"