summaryrefslogtreecommitdiffstats
path: root/src/plugins/imageformats/jpeg/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/imageformats/jpeg/CMakeLists.txt')
-rw-r--r--src/plugins/imageformats/jpeg/CMakeLists.txt15
1 files changed, 11 insertions, 4 deletions
diff --git a/src/plugins/imageformats/jpeg/CMakeLists.txt b/src/plugins/imageformats/jpeg/CMakeLists.txt
index 39c45bc2fe..1c4627cb4f 100644
--- a/src/plugins/imageformats/jpeg/CMakeLists.txt
+++ b/src/plugins/imageformats/jpeg/CMakeLists.txt
@@ -1,19 +1,26 @@
# Generated from jpeg.pro.
+qt_find_package(JPEG) # special case
+
#####################################################################
## qjpeg Plugin:
#####################################################################
-qt_find_package(JPEG) # special case
-
add_qt_plugin(qjpeg
TYPE imageformats
SOURCES
main.cpp main.h
qjpeghandler.cpp qjpeghandler_p.h
LIBRARIES
- Qt::Gui
- Qt::CorePrivate
+ # Qt::CorePrivate # special case: remove
Qt::GuiPrivate
+ PUBLIC_LIBRARIES # special case
JPEG::JPEG
+ # Qt::Core # special case: remove
+ Qt::Gui # special case
)
+
+#### Keys ignored in scope 1:.:.:jpeg.pro:<TRUE>:
+# OTHER_FILES = "jpeg.json"
+# PLUGIN_CLASS_NAME = "QJpegPlugin"
+# _LOADED = "qt_plugin"