summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/cocoa/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/platforms/cocoa/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/cocoa/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/plugins/platforms/cocoa/CMakeLists.txt b/src/plugins/platforms/cocoa/CMakeLists.txt
index 7a61231509..51d7038950 100644
--- a/src/plugins/platforms/cocoa/CMakeLists.txt
+++ b/src/plugins/platforms/cocoa/CMakeLists.txt
@@ -16,9 +16,12 @@ qt_internal_add_plugin(QCocoaIntegrationPlugin
qcocoaapplicationdelegate.h qcocoaapplicationdelegate.mm
qcocoabackingstore.h qcocoabackingstore.mm
qcocoaclipboard.h qcocoaclipboard.mm
+ qcocoacolordialoghelper.h qcocoacolordialoghelper.mm
qcocoacursor.h qcocoacursor.mm
qcocoadrag.h qcocoadrag.mm
qcocoaeventdispatcher.h qcocoaeventdispatcher.mm
+ qcocoafiledialoghelper.h qcocoafiledialoghelper.mm
+ qcocoafontdialoghelper.h qcocoafontdialoghelper.mm
qcocoahelpers.h qcocoahelpers.mm
qcocoainputcontext.h qcocoainputcontext.mm
qcocoaintegration.h qcocoaintegration.mm
@@ -91,8 +94,6 @@ qt_add_resource(QCocoaIntegrationPlugin "qcocoaresources"
qt_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_opengl
SOURCES
qcocoaglcontext.h qcocoaglcontext.mm
- PUBLIC_LIBRARIES
- Qt::OpenGLPrivate
)
qt_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_vulkan