summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/cocoa/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/platforms/cocoa/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/cocoa/CMakeLists.txt18
1 files changed, 0 insertions, 18 deletions
diff --git a/src/plugins/platforms/cocoa/CMakeLists.txt b/src/plugins/platforms/cocoa/CMakeLists.txt
index 9d578e7eed..11f3f99d8d 100644
--- a/src/plugins/platforms/cocoa/CMakeLists.txt
+++ b/src/plugins/platforms/cocoa/CMakeLists.txt
@@ -1,7 +1,6 @@
# Generated from cocoa.pro.
# special case:
-qt_find_package(Cups PROVIDED_TARGETS Cups::Cups)
#####################################################################
## QCocoaIntegrationPlugin Plugin:
@@ -55,7 +54,6 @@ qt_internal_add_plugin(QCocoaIntegrationPlugin
${FWIOSurface}
${FWMetal}
${FWQuartzCore}
- Cups::Cups
Qt::Core
Qt::CorePrivate
Qt::Gui
@@ -110,25 +108,9 @@ qt_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_sessionmanager
qcocoasessionmanager.cpp qcocoasessionmanager.h
)
-qt_extend_target(QCocoaIntegrationPlugin CONDITION TARGET Qt::Widgets
- SOURCES
- qpaintengine_mac.mm qpaintengine_mac_p.h
- PUBLIC_LIBRARIES
- Qt::WidgetsPrivate
-)
-
#### Keys ignored in scope 7:.:.:cocoa.pro:TARGET Qt::Widgets:
# QT_FOR_CONFIG = "widgets"
-qt_extend_target(QCocoaIntegrationPlugin CONDITION TARGET Qt::PrintSupport AND TARGET Qt::Widgets
- SOURCES
- qcocoaprintdevice.h qcocoaprintdevice.mm
- qcocoaprintersupport.h qcocoaprintersupport.mm
- qprintengine_mac.mm qprintengine_mac_p.h
- PUBLIC_LIBRARIES
- Qt::PrintSupportPrivate
-)
-
qt_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_colordialog AND TARGET Qt::Widgets
SOURCES
qcocoacolordialoghelper.h qcocoacolordialoghelper.mm