summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/eglfs/deviceintegration/eglfs_kms_support/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/platforms/eglfs/deviceintegration/eglfs_kms_support/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/eglfs/deviceintegration/eglfs_kms_support/CMakeLists.txt15
1 files changed, 5 insertions, 10 deletions
diff --git a/src/plugins/platforms/eglfs/deviceintegration/eglfs_kms_support/CMakeLists.txt b/src/plugins/platforms/eglfs/deviceintegration/eglfs_kms_support/CMakeLists.txt
index 08c313df2c..5fcc0e1b18 100644
--- a/src/plugins/platforms/eglfs/deviceintegration/eglfs_kms_support/CMakeLists.txt
+++ b/src/plugins/platforms/eglfs/deviceintegration/eglfs_kms_support/CMakeLists.txt
@@ -1,10 +1,11 @@
-# Generated from eglfs_kms_support.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
-## EglFsKmsSupport Module:
+## EglFsKmsSupportPrivate Module:
#####################################################################
-qt_internal_add_module(EglFsKmsSupport
+qt_internal_add_module(EglFsKmsSupportPrivate
CONFIG_MODULE_NAME eglfs_kms_support
INTERNAL_MODULE
SOURCES
@@ -23,11 +24,5 @@ qt_internal_add_module(EglFsKmsSupport
Qt::Gui
Qt::GuiPrivate
Qt::KmsSupportPrivate
+ NO_GENERATE_CPP_EXPORTS
)
-
-# begin special case
-qt_internal_extend_target(EglFsKmsSupport
- CONDITION QNX
- COMPILE_OPTIONS -fpermissive
-)
-# end special case