summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/eglfs/deviceintegration/eglfs_kms_support/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/platforms/eglfs/deviceintegration/eglfs_kms_support/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/eglfs/deviceintegration/eglfs_kms_support/CMakeLists.txt18
1 files changed, 12 insertions, 6 deletions
diff --git a/src/plugins/platforms/eglfs/deviceintegration/eglfs_kms_support/CMakeLists.txt b/src/plugins/platforms/eglfs/deviceintegration/eglfs_kms_support/CMakeLists.txt
index 96cabe9f1e..fd7ba3cefb 100644
--- a/src/plugins/platforms/eglfs/deviceintegration/eglfs_kms_support/CMakeLists.txt
+++ b/src/plugins/platforms/eglfs/deviceintegration/eglfs_kms_support/CMakeLists.txt
@@ -1,7 +1,5 @@
# Generated from eglfs_kms_support.pro.
-qt_find_package(Libdrm)
-
#####################################################################
## EglFsKmsSupport Module:
#####################################################################
@@ -19,11 +17,19 @@ add_qt_module(EglFsKmsSupport
../../api
LIBRARIES
Qt::CorePrivate
- Qt::GuiPrivate
+ Qt::EdidSupportPrivate
Qt::EglFSDeviceIntegrationPrivate
+ Qt::GuiPrivate
Qt::KmsSupportPrivate
- Qt::EdidSupportPrivate
+ PUBLIC_LIBRARIES
Libdrm::Libdrm
- # CONFIG = "no_module_headers" "internal_module" "egl"
- # _LOADED = "qt_module"
+ Qt::Core
+ Qt::EdidSupport
+ Qt::EglFSDeviceIntegration
+ Qt::Gui
+ Qt::KmsSupport
)
+
+#### Keys ignored in scope 1:.:.:eglfs_kms_support.pro:<TRUE>:
+# CONFIG = "no_module_headers" "internal_module" "egl"
+# _LOADED = "qt_module"