summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/eglfs/deviceintegration/eglfs_openwfd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/platforms/eglfs/deviceintegration/eglfs_openwfd/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/eglfs/deviceintegration/eglfs_openwfd/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/plugins/platforms/eglfs/deviceintegration/eglfs_openwfd/CMakeLists.txt b/src/plugins/platforms/eglfs/deviceintegration/eglfs_openwfd/CMakeLists.txt
new file mode 100644
index 0000000000..7e2362e627
--- /dev/null
+++ b/src/plugins/platforms/eglfs/deviceintegration/eglfs_openwfd/CMakeLists.txt
@@ -0,0 +1,22 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## QEglFSOpenWFDIntegrationPlugin Plugin:
+#####################################################################
+
+qt_internal_add_plugin(QEglFSOpenWFDIntegrationPlugin
+ OUTPUT_NAME qeglfs-openwfd-integration
+ PLUGIN_TYPE egldeviceintegrations
+ SOURCES
+ qeglfsopenwfdintegration.cpp qeglfsopenwfdintegration.h
+ qeglfsopenwfdmain.cpp
+ INCLUDE_DIRECTORIES
+ ../../api
+ LIBRARIES
+ Qt::Core
+ Qt::CorePrivate
+ Qt::EglFSDeviceIntegrationPrivate
+ Qt::Gui
+ Qt::GuiPrivate
+)