summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/offscreen/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/platforms/offscreen/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/offscreen/CMakeLists.txt22
1 files changed, 8 insertions, 14 deletions
diff --git a/src/plugins/platforms/offscreen/CMakeLists.txt b/src/plugins/platforms/offscreen/CMakeLists.txt
index 43c8bdc17b..63474c3760 100644
--- a/src/plugins/platforms/offscreen/CMakeLists.txt
+++ b/src/plugins/platforms/offscreen/CMakeLists.txt
@@ -1,12 +1,12 @@
# Generated from offscreen.pro.
#####################################################################
-## qoffscreen Plugin:
+## QOffscreenIntegrationPlugin Plugin:
#####################################################################
-add_qt_plugin(qoffscreen
+qt_add_plugin(QOffscreenIntegrationPlugin
+ OUTPUT_NAME qoffscreen
TYPE platforms
- CLASS_NAME QOffscreenIntegrationPlugin
DEFAULT_IF ${QT_QPA_DEFAULT_PLATFORM} MATCHES offscreen # special case
SOURCES
main.cpp
@@ -15,32 +15,26 @@ add_qt_plugin(qoffscreen
qoffscreenwindow.cpp qoffscreenwindow.h
DEFINES
QT_NO_FOREACH
- LIBRARIES
+ PUBLIC_LIBRARIES
+ Qt::Core
Qt::CorePrivate
Qt::EventDispatcherSupportPrivate
Qt::FontDatabaseSupportPrivate
- Qt::GuiPrivate
- PUBLIC_LIBRARIES
- Qt::Core
- Qt::EventDispatcherSupport
- Qt::FontDatabaseSupport
Qt::Gui
+ Qt::GuiPrivate
)
#### Keys ignored in scope 1:.:.:offscreen.pro:<TRUE>:
# OTHER_FILES = "offscreen.json"
-# _LOADED = "qt_plugin"
## Scopes:
#####################################################################
-extend_target(qoffscreen CONDITION QT_FEATURE_opengl AND QT_FEATURE_xlib AND NOT QT_FEATURE_opengles2
+qt_extend_target(QOffscreenIntegrationPlugin CONDITION QT_FEATURE_opengl AND QT_FEATURE_xlib AND NOT QT_FEATURE_opengles2
SOURCES
qoffscreenintegration_x11.cpp qoffscreenintegration_x11.h
- LIBRARIES
- Qt::GlxSupportPrivate
PUBLIC_LIBRARIES
- Qt::GlxSupport
+ Qt::GlxSupportPrivate
)
#### Keys ignored in scope 3:.:.:offscreen.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN: