summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/qnx/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/platforms/qnx/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/qnx/CMakeLists.txt27
1 files changed, 14 insertions, 13 deletions
diff --git a/src/plugins/platforms/qnx/CMakeLists.txt b/src/plugins/platforms/qnx/CMakeLists.txt
index b49c5be162..9fb412d8a4 100644
--- a/src/plugins/platforms/qnx/CMakeLists.txt
+++ b/src/plugins/platforms/qnx/CMakeLists.txt
@@ -1,4 +1,5 @@
-# Generated from qnx.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## QQnxIntegrationPlugin Plugin:
@@ -6,8 +7,8 @@
qt_internal_add_plugin(QQnxIntegrationPlugin
OUTPUT_NAME qqnx
- TYPE platforms
- DEFAULT_IF ${QT_QPA_DEFAULT_PLATFORM} MATCHES qnx # special case
+ PLUGIN_TYPE platforms
+ DEFAULT_IF ${QT_QPA_DEFAULT_PLATFORM} MATCHES qnx
SOURCES
main.cpp main.h
qqnxabstractcover.h
@@ -30,6 +31,12 @@ qt_internal_add_plugin(QQnxIntegrationPlugin
qqnxscreeneventthread.cpp qqnxscreeneventthread.h
qqnxservices.cpp qqnxservices.h
qqnxwindow.cpp qqnxwindow.h
+ NO_PCH_SOURCES
+ qqnxclipboard.cpp # undef QT_NO_FOREACH
+ qqnxintegration.cpp # undef QT_NO_FOREACH
+ qqnxscreen.cpp # undef QT_NO_FOREACH
+ qqnxscreeneventhandler.cpp # undef QT_NO_FOREACH
+ qqnxwindow.cpp # undef QT_NO_FOREACH
LIBRARIES
Qt::Core
Qt::CorePrivate
@@ -38,9 +45,6 @@ qt_internal_add_plugin(QQnxIntegrationPlugin
screen
)
-#### Keys ignored in scope 1:.:.:qnx.pro:<TRUE>:
-# OTHER_FILES = "qnx.json"
-
## Scopes:
#####################################################################
@@ -48,7 +52,7 @@ qt_internal_extend_target(QQnxIntegrationPlugin CONDITION QT_FEATURE_egl
SOURCES
qqnxeglwindow.cpp qqnxeglwindow.h
qqnxglcontext.cpp qqnxglcontext.h
- PUBLIC_LIBRARIES
+ LIBRARIES
EGL::EGL
)
@@ -58,14 +62,14 @@ qt_internal_extend_target(QQnxIntegrationPlugin CONDITION QT_FEATURE_qqnx_pps
qqnxnavigatoreventnotifier.cpp qqnxnavigatoreventnotifier.h
qqnxnavigatorpps.cpp qqnxnavigatorpps.h
qqnxvirtualkeyboardpps.cpp qqnxvirtualkeyboardpps.h
- PUBLIC_LIBRARIES
+ LIBRARIES
PPS::PPS
)
qt_internal_extend_target(QQnxIntegrationPlugin CONDITION QT_FEATURE_clipboard AND QT_FEATURE_qqnx_pps
SOURCES
qqnxclipboard.cpp qqnxclipboard.h
- PUBLIC_LIBRARIES
+ LIBRARIES
clipboard
)
@@ -84,9 +88,6 @@ qt_internal_extend_target(QQnxIntegrationPlugin CONDITION lgmon
qqnxlgmon.cpp
DEFINES
QQNX_LGMON
- PUBLIC_LIBRARIES
+ LIBRARIES
lgmon
)
-
-#### Keys ignored in scope 8:.:.:qnx.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN:
-# PLUGIN_EXTENDS = "-"