summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/vnc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/platforms/vnc/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/vnc/CMakeLists.txt18
1 files changed, 5 insertions, 13 deletions
diff --git a/src/plugins/platforms/vnc/CMakeLists.txt b/src/plugins/platforms/vnc/CMakeLists.txt
index 502cff06db..cb84355d81 100644
--- a/src/plugins/platforms/vnc/CMakeLists.txt
+++ b/src/plugins/platforms/vnc/CMakeLists.txt
@@ -16,23 +16,17 @@ qt_add_plugin(QVncIntegrationPlugin
qvncscreen.cpp qvncscreen.h
DEFINES
QT_NO_FOREACH
- LIBRARIES
+ PUBLIC_LIBRARIES
+ Qt::Core
Qt::CorePrivate
Qt::EventDispatcherSupportPrivate
Qt::FbSupportPrivate
Qt::FontDatabaseSupportPrivate
+ Qt::Gui
Qt::GuiPrivate
+ Qt::Network
Qt::ServiceSupportPrivate
Qt::ThemeSupportPrivate
- PUBLIC_LIBRARIES
- Qt::Core
- Qt::EventDispatcherSupport
- Qt::FbSupport
- Qt::FontDatabaseSupport
- Qt::Gui
- Qt::Network
- Qt::ServiceSupport
- Qt::ThemeSupport
)
#### Keys ignored in scope 1:.:.:vnc.pro:<TRUE>:
@@ -42,10 +36,8 @@ qt_add_plugin(QVncIntegrationPlugin
#####################################################################
qt_extend_target(QVncIntegrationPlugin CONDITION TARGET Qt::InputSupportPrivate
- LIBRARIES
- Qt::InputSupportPrivate
PUBLIC_LIBRARIES
- Qt::InputSupport
+ Qt::InputSupportPrivate
)
#### Keys ignored in scope 3:.:.:vnc.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN: