summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/xcb/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/platforms/xcb/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/xcb/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/plugins/platforms/xcb/CMakeLists.txt b/src/plugins/platforms/xcb/CMakeLists.txt
index 1d481832f1..6e4388cc3f 100644
--- a/src/plugins/platforms/xcb/CMakeLists.txt
+++ b/src/plugins/platforms/xcb/CMakeLists.txt
@@ -71,9 +71,9 @@ qt_disable_apple_app_extension_api_only(XcbQpa)
## Scopes:
#####################################################################
-qt_extend_target(XcbQpa CONDITION TARGET Qt::PlatformCompositorSupportPrivate
+qt_extend_target(XcbQpa CONDITION QT_FEATURE_opengl
PUBLIC_LIBRARIES
- Qt::PlatformCompositorSupportPrivate
+ Qt::OpenGLPrivate
)
qt_extend_target(XcbQpa CONDITION TARGET Qt::LinuxAccessibilitySupportPrivate