summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/xcb/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/platforms/xcb/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/xcb/CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/src/plugins/platforms/xcb/CMakeLists.txt b/src/plugins/platforms/xcb/CMakeLists.txt
index 9f94791550..aa2c0732f2 100644
--- a/src/plugins/platforms/xcb/CMakeLists.txt
+++ b/src/plugins/platforms/xcb/CMakeLists.txt
@@ -54,8 +54,8 @@ add_qt_module(XcbQpa
qxcbwmsupport.cpp qxcbwmsupport.h
qxcbxsettings.cpp qxcbxsettings.h
DEFINES
- QT_NO_FOREACH
QT_BUILD_XCB_PLUGIN
+ QT_NO_FOREACH
INCLUDE_DIRECTORIES
gl_integrations
LIBRARIES
@@ -68,7 +68,6 @@ add_qt_module(XcbQpa
Qt::XkbCommonSupportPrivate
PkgConfig::XKB_COMMON_X11 # special case
PUBLIC_LIBRARIES
- ${CMAKE_DL_LIBS}
Qt::Core
Qt::EdidSupport
Qt::FontDatabaseSupport
@@ -151,9 +150,14 @@ extend_target(XcbQpa CONDITION QT_FEATURE_xkb
XKB::XKB
)
+extend_target(XcbQpa CONDITION QT_FEATURE_dlopen
+ PUBLIC_LIBRARIES
+ ${CMAKE_DL_LIBS}
+)
+
extend_target(XcbQpa CONDITION CLANG AND NOT ICC
COMPILE_OPTIONS
- "-ftemplate-depth=1024"
+ -ftemplate-depth=1024
)
extend_target(XcbQpa CONDITION QT_FEATURE_xcb_native_painting
@@ -184,6 +188,7 @@ extend_target(XcbQpa CONDITION QT_FEATURE_fontconfig AND QT_FEATURE_xcb_native_p
add_qt_plugin(qxcb
TYPE platforms
+ CLASS_NAME QXcbIntegrationPlugin
SOURCES
qxcbmain.cpp
DEFINES
@@ -201,6 +206,7 @@ add_qt_plugin(qxcb
#### Keys ignored in scope 24:.:.:xcb-plugin.pro:<TRUE>:
# OTHER_FILES = "xcb.json" "README"
# PLUGIN_CLASS_NAME = "QXcbIntegrationPlugin"
+# PLUGIN_TYPE = "platforms"
# _LOADED = "qt_plugin"
## Scopes: