summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/xcb/gl_integrations/xcb_glx/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/platforms/xcb/gl_integrations/xcb_glx/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/xcb/gl_integrations/xcb_glx/CMakeLists.txt47
1 files changed, 47 insertions, 0 deletions
diff --git a/src/plugins/platforms/xcb/gl_integrations/xcb_glx/CMakeLists.txt b/src/plugins/platforms/xcb/gl_integrations/xcb_glx/CMakeLists.txt
new file mode 100644
index 0000000000..940cbe12d1
--- /dev/null
+++ b/src/plugins/platforms/xcb/gl_integrations/xcb_glx/CMakeLists.txt
@@ -0,0 +1,47 @@
+# Generated from xcb_glx.pro.
+
+#####################################################################
+## qxcb-glx-integration Plugin:
+#####################################################################
+
+add_qt_plugin(qxcb-glx-integration
+ TYPE xcbglintegrations
+ CLASS_NAME QXcbGlxIntegrationPlugin
+ SOURCES
+ qglxintegration.cpp qglxintegration.h
+ qxcbglxintegration.cpp qxcbglxintegration.h
+ qxcbglxmain.cpp
+ qxcbglxnativeinterfacehandler.cpp qxcbglxnativeinterfacehandler.h
+ qxcbglxwindow.cpp qxcbglxwindow.h
+ DEFINES
+ QT_NO_FOREACH
+ INCLUDE_DIRECTORIES
+ ..
+ ../..
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GlxSupportPrivate
+ Qt::GuiPrivate
+ Qt::XcbQpaPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::GlxSupport
+ Qt::Gui
+ Qt::XcbQpa
+)
+
+#### Keys ignored in scope 1:.:.:xcb_glx.pro:<TRUE>:
+# _LOADED = "qt_plugin" "qt_build_paths"
+
+## Scopes:
+#####################################################################
+
+extend_target(qxcb-glx-integration CONDITION QT_FEATURE_xcb_glx
+ PUBLIC_LIBRARIES
+ XCB::GLX
+)
+
+extend_target(qxcb-glx-integration CONDITION QT_FEATURE_dlopen AND NOT static
+ PUBLIC_LIBRARIES
+ ${CMAKE_DL_LIBS}
+)