summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/xcb/gl_integrations/xcb_glx/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/platforms/xcb/gl_integrations/xcb_glx/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/xcb/gl_integrations/xcb_glx/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/plugins/platforms/xcb/gl_integrations/xcb_glx/CMakeLists.txt b/src/plugins/platforms/xcb/gl_integrations/xcb_glx/CMakeLists.txt
index 9ebc98ea53..80f785a2f0 100644
--- a/src/plugins/platforms/xcb/gl_integrations/xcb_glx/CMakeLists.txt
+++ b/src/plugins/platforms/xcb/gl_integrations/xcb_glx/CMakeLists.txt
@@ -18,7 +18,7 @@ qt_internal_add_plugin(QXcbGlxIntegrationPlugin
INCLUDE_DIRECTORIES
..
../..
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Core
Qt::CorePrivate
Qt::Gui
@@ -30,12 +30,12 @@ qt_internal_add_plugin(QXcbGlxIntegrationPlugin
#####################################################################
qt_internal_extend_target(QXcbGlxIntegrationPlugin CONDITION QT_FEATURE_xcb_glx
- PUBLIC_LIBRARIES
+ LIBRARIES
XCB::GLX
)
qt_internal_extend_target(QXcbGlxIntegrationPlugin
CONDITION QT_FEATURE_dlopen AND QT_BUILD_SHARED_LIBS
- PUBLIC_LIBRARIES
+ LIBRARIES
${CMAKE_DL_LIBS}
)