summaryrefslogtreecommitdiffstats
path: root/src/plugins/platformthemes/gtk3/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/platformthemes/gtk3/CMakeLists.txt')
-rw-r--r--src/plugins/platformthemes/gtk3/CMakeLists.txt16
1 files changed, 7 insertions, 9 deletions
diff --git a/src/plugins/platformthemes/gtk3/CMakeLists.txt b/src/plugins/platformthemes/gtk3/CMakeLists.txt
index 17902f4b95..4e56e4a6b3 100644
--- a/src/plugins/platformthemes/gtk3/CMakeLists.txt
+++ b/src/plugins/platformthemes/gtk3/CMakeLists.txt
@@ -4,12 +4,12 @@ qt_find_package(GTK3) # special case
qt_find_package(X11) # special case
#####################################################################
-## qgtk3 Plugin:
+## QGtk3ThemePlugin Plugin:
#####################################################################
-add_qt_plugin(qgtk3
+qt_add_plugin(QGtk3ThemePlugin
+ OUTPUT_NAME qgtk3
TYPE platformthemes
- CLASS_NAME QGtk3ThemePlugin
SOURCES
main.cpp
qgtk3dialoghelpers.cpp qgtk3dialoghelpers.h
@@ -17,18 +17,16 @@ add_qt_plugin(qgtk3
qgtk3theme.cpp qgtk3theme.h
DEFINES
GDK_VERSION_MIN_REQUIRED=GDK_VERSION_3_6
- LIBRARIES
- Qt::CorePrivate
- Qt::GuiPrivate
- Qt::ThemeSupportPrivate
+ LIBRARIES # special case
X11::X11 # special case
PUBLIC_LIBRARIES
PkgConfig::GTK3
Qt::Core
+ Qt::CorePrivate
Qt::Gui
- Qt::ThemeSupport
+ Qt::GuiPrivate
+ Qt::ThemeSupportPrivate
)
#### Keys ignored in scope 1:.:.:gtk3.pro:<TRUE>:
# PLUGIN_EXTENDS = "-"
-# _LOADED = "qt_plugin"