summaryrefslogtreecommitdiffstats
path: root/src/plugins/platformthemes/gtk3/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/platformthemes/gtk3/CMakeLists.txt')
-rw-r--r--src/plugins/platformthemes/gtk3/CMakeLists.txt26
1 files changed, 18 insertions, 8 deletions
diff --git a/src/plugins/platformthemes/gtk3/CMakeLists.txt b/src/plugins/platformthemes/gtk3/CMakeLists.txt
index da61354237..becfcccd35 100644
--- a/src/plugins/platformthemes/gtk3/CMakeLists.txt
+++ b/src/plugins/platformthemes/gtk3/CMakeLists.txt
@@ -1,7 +1,11 @@
-# Generated from gtk3.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
-qt_find_package(GTK3) # special case
-qt_find_package(X11) # special case
+qt_find_package(GTK3)
+
+if(QT_FEATURE_xlib)
+ qt_find_package(X11)
+endif()
#####################################################################
## QGtk3ThemePlugin Plugin:
@@ -9,23 +13,29 @@ qt_find_package(X11) # special case
qt_internal_add_plugin(QGtk3ThemePlugin
OUTPUT_NAME qgtk3
- TYPE platformthemes
+ PLUGIN_TYPE platformthemes
DEFAULT_IF FALSE
SOURCES
main.cpp
qgtk3dialoghelpers.cpp qgtk3dialoghelpers.h
qgtk3menu.cpp qgtk3menu.h
qgtk3theme.cpp qgtk3theme.h
+ qgtk3interface.cpp qgtk3interface_p.h
+ qgtk3storage.cpp qgtk3storage_p.h
+ qgtk3json.cpp qgtk3json_p.h
+ NO_PCH_SOURCES
+ qgtk3dialoghelpers.cpp # undef QT_NO_FOREACH
DEFINES
GDK_VERSION_MIN_REQUIRED=GDK_VERSION_3_6
- LIBRARIES # special case
+ LIBRARIES
PkgConfig::GTK3
Qt::Core
Qt::CorePrivate
Qt::Gui
Qt::GuiPrivate
- X11::X11 # special case
)
-#### Keys ignored in scope 1:.:.:gtk3.pro:<TRUE>:
-# PLUGIN_EXTENDS = "-"
+qt_internal_extend_target(QGtk3ThemePlugin CONDITION QT_FEATURE_xlib
+ LIBRARIES
+ X11::X11
+)