summaryrefslogtreecommitdiffstats
path: root/src/plugins/platformthemes/gtk3/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/platformthemes/gtk3/CMakeLists.txt')
-rw-r--r--src/plugins/platformthemes/gtk3/CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/src/plugins/platformthemes/gtk3/CMakeLists.txt b/src/plugins/platformthemes/gtk3/CMakeLists.txt
index 9b1ed2242e..4e56e4a6b3 100644
--- a/src/plugins/platformthemes/gtk3/CMakeLists.txt
+++ b/src/plugins/platformthemes/gtk3/CMakeLists.txt
@@ -17,16 +17,15 @@ qt_add_plugin(QGtk3ThemePlugin
qgtk3theme.cpp qgtk3theme.h
DEFINES
GDK_VERSION_MIN_REQUIRED=GDK_VERSION_3_6
- LIBRARIES
- Qt::CorePrivate
- Qt::GuiPrivate
- Qt::ThemeSupportPrivate
+ LIBRARIES # special case
X11::X11 # special case
PUBLIC_LIBRARIES
PkgConfig::GTK3
Qt::Core
+ Qt::CorePrivate
Qt::Gui
- Qt::ThemeSupport
+ Qt::GuiPrivate
+ Qt::ThemeSupportPrivate
)
#### Keys ignored in scope 1:.:.:gtk3.pro:<TRUE>: