summaryrefslogtreecommitdiffstats
path: root/src/plugins/platformthemes/gtk3/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/platformthemes/gtk3/CMakeLists.txt')
-rw-r--r--src/plugins/platformthemes/gtk3/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/plugins/platformthemes/gtk3/CMakeLists.txt b/src/plugins/platformthemes/gtk3/CMakeLists.txt
new file mode 100644
index 0000000000..af11ddb80a
--- /dev/null
+++ b/src/plugins/platformthemes/gtk3/CMakeLists.txt
@@ -0,0 +1,29 @@
+# Generated from gtk3.pro.
+
+qt_find_package(GTK3)
+qt_find_package(X11)
+
+#####################################################################
+## qgtk3 Plugin:
+#####################################################################
+
+add_qt_plugin(qgtk3
+ TYPE platformthemes
+ SOURCES
+ main.cpp
+ qgtk3dialoghelpers.cpp qgtk3dialoghelpers.h
+ qgtk3menu.cpp qgtk3menu.h
+ qgtk3theme.cpp qgtk3theme.h
+ DEFINES
+ GDK_VERSION_MIN_REQUIRED=GDK_VERSION_3_6
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::ThemeSupportPrivate
+ PkgConfig::GTK3
+ X11::X11
+ # CONFIG = "X11"
+ # PLUGIN_CLASS_NAME = "QGtk3ThemePlugin"
+ # PLUGIN_EXTENDS = "-"
+ # _LOADED = "qt_plugin"
+)