summaryrefslogtreecommitdiffstats
path: root/src/plugins/sqldrivers/psql/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/sqldrivers/psql/CMakeLists.txt')
-rw-r--r--src/plugins/sqldrivers/psql/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/plugins/sqldrivers/psql/CMakeLists.txt b/src/plugins/sqldrivers/psql/CMakeLists.txt
new file mode 100644
index 0000000000..7b854c365f
--- /dev/null
+++ b/src/plugins/sqldrivers/psql/CMakeLists.txt
@@ -0,0 +1,28 @@
+# FIXME cmake FindPostgreSQL is more exhaustive than the check we have for libpq-fe.h
+# it also checks for catalog/pg_type.h which is a more internal include, we should
+# add a way to tell cmake FindPostgreSQL to optionally only look for the libpq-fe.h one
+qt_find_package(PostgreSQL) # special case
+
+#####################################################################
+## qsqlpsql Plugin:
+#####################################################################
+
+add_qt_plugin(qsqlpsql
+ TYPE sqldrivers
+ SOURCES
+ main.cpp
+ qsql_psql.cpp qsql_psql_p.h
+ DEFINES
+ QT_NO_CAST_TO_ASCII
+ QT_NO_CAST_FROM_ASCII
+ LIBRARIES
+ PostgreSQL::PostgreSQL
+ Qt::Core
+ Qt::CorePrivate
+ Qt::SqlPrivate
+)
+
+#### Keys ignored in scope 1:.:psql.pro:<NONE>:
+# OTHER_FILES = "psql.json"
+# PLUGIN_CLASS_NAME = "QPSQLDriverPlugin"
+# _LOADED = "qt_plugin"