summaryrefslogtreecommitdiffstats
path: root/src/sql/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/sql/CMakeLists.txt')
-rw-r--r--src/sql/CMakeLists.txt9
1 files changed, 3 insertions, 6 deletions
diff --git a/src/sql/CMakeLists.txt b/src/sql/CMakeLists.txt
index b76302655c..0a51f62c4b 100644
--- a/src/sql/CMakeLists.txt
+++ b/src/sql/CMakeLists.txt
@@ -1,7 +1,5 @@
# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR GPL-3.0-only WITH Qt-GPL-exception-1.0
-
-# Generated from sql.pro.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## Sql Module:
@@ -25,8 +23,10 @@ qt_internal_add_module(Sql
kernel/qtsqlglobal.h kernel/qtsqlglobal_p.h
DEFINES
QT_NO_CAST_FROM_ASCII
+ QT_NO_CONTEXTLESS_CONNECT
QT_NO_FOREACH
QT_NO_USING_NAMESPACE
+ QT_USE_NODISCARD_FILE_OPEN
LIBRARIES
Qt::CorePrivate
PUBLIC_LIBRARIES
@@ -40,9 +40,6 @@ qt_internal_add_module(Sql
GENERATE_CPP_EXPORTS
)
-#### Keys ignored in scope 1:.:.:sql.pro:<TRUE>:
-# SQL_P = "sql"
-
## Scopes:
#####################################################################