summaryrefslogtreecommitdiffstats
path: root/src/tools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/CMakeLists.txt')
-rw-r--r--src/tools/CMakeLists.txt21
1 files changed, 18 insertions, 3 deletions
diff --git a/src/tools/CMakeLists.txt b/src/tools/CMakeLists.txt
index 13a870ac9e..df0d2c7016 100644
--- a/src/tools/CMakeLists.txt
+++ b/src/tools/CMakeLists.txt
@@ -1,3 +1,11 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+# The configure.cmake here does not get picked up automatically.
+# Manually evaluate tool-related features.
+include("${CMAKE_CURRENT_SOURCE_DIR}/configure.cmake")
+qt_feature_evaluate_features("${CMAKE_CURRENT_SOURCE_DIR}/configure.cmake")
+
add_subdirectory(uic)
if (QT_FEATURE_dbus)
add_subdirectory(qdbuscpp2xml)
@@ -9,10 +17,17 @@ if (QT_FEATURE_commandlineparser)
add_subdirectory(qtpaths)
endif()
-# Only include the following tools when performing a host build
-if(NOT CMAKE_CROSSCOMPILING)
+if(QT_FEATURE_androiddeployqt)
add_subdirectory(androiddeployqt)
- if(QT_FEATURE_gui AND QT_FEATURE_systemsemaphore)
+ if(QT_FEATURE_gui AND QT_FEATURE_process AND QT_FEATURE_systemsemaphore)
add_subdirectory(androidtestrunner)
endif()
endif()
+
+if(QT_FEATURE_macdeployqt)
+ add_subdirectory(macdeployqt)
+endif()
+
+if(QT_FEATURE_windeployqt)
+ add_subdirectory(windeployqt)
+endif()