summaryrefslogtreecommitdiffstats
path: root/src/tools/qdbuscpp2xml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/qdbuscpp2xml/CMakeLists.txt')
-rw-r--r--src/tools/qdbuscpp2xml/CMakeLists.txt25
1 files changed, 4 insertions, 21 deletions
diff --git a/src/tools/qdbuscpp2xml/CMakeLists.txt b/src/tools/qdbuscpp2xml/CMakeLists.txt
index 568919dfd7..781c1835bc 100644
--- a/src/tools/qdbuscpp2xml/CMakeLists.txt
+++ b/src/tools/qdbuscpp2xml/CMakeLists.txt
@@ -1,7 +1,5 @@
# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR GPL-3.0-only WITH Qt-GPL-exception-1.0
-
-# Generated from qdbuscpp2xml.pro.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## qdbuscpp2xml Tool:
@@ -9,8 +7,10 @@
qt_get_tool_target_name(target_name qdbuscpp2xml)
qt_internal_add_tool(${target_name}
+ TRY_RUN
+ TRY_RUN_FLAGS "-V"
TARGET_DESCRIPTION "Qt D-Bus C++ to XML Compiler"
- TOOLS_TARGET DBus # special case
+ TOOLS_TARGET DBus
SOURCES
../moc/cbordevice.h
../moc/collectjson.cpp ../moc/collectjson.h
@@ -32,22 +32,5 @@ qt_internal_add_tool(${target_name}
LIBRARIES
Qt::CorePrivate
Qt::DBusPrivate
- # COMPILE_OPTIONS # special case
- # "$$QT_HOST_CFLAGS_DBUS"
- # QMAKE_TARGET_DESCRIPTION = "Qt D-Bus C++ to XML Compiler"
- # _LOADED = "qt_tool"
- # _OPTION = "host_build"
)
qt_internal_return_unless_building_tools()
-
-#### Keys ignored in scope 1:.:.:qdbuscpp2xml.pro:<TRUE>:
-# QMAKE_TARGET_DESCRIPTION = "Qt D-Bus C++ to XML Compiler"
-# _OPTION = "host_build"
-
-## Scopes:
-#####################################################################
-
-# special case begin
-# qt_internal_extend_target(qdbuscpp2xml CONDITION force_bootstrap [...])
-# qt_internal_extend_target(qdbuscpp2xml CONDITION NOT force_bootstrap [...])
-# special case end