summaryrefslogtreecommitdiffstats
path: root/src/tools/uic/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/uic/CMakeLists.txt')
-rw-r--r--src/tools/uic/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/tools/uic/CMakeLists.txt b/src/tools/uic/CMakeLists.txt
new file mode 100644
index 0000000000..0c40af3540
--- /dev/null
+++ b/src/tools/uic/CMakeLists.txt
@@ -0,0 +1,16 @@
+add_qt_tool(uic
+ SOURCES
+ cpp/cppwritedeclaration.cpp
+ cpp/cppwriteincludes.cpp
+ cpp/cppwriteinitialization.cpp
+ customwidgetsinfo.cpp
+ databaseinfo.cpp
+ driver.cpp
+ main.cpp
+ treewalker.cpp
+ ui4.cpp
+ uic.cpp
+ validator.cpp
+ INCLUDE_DIRECTORIES cpp
+ DEFINES QT_UIC QT_UIC_CPP_GENERATOR
+)