summaryrefslogtreecommitdiffstats
path: root/src/winmain/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/winmain/CMakeLists.txt')
-rw-r--r--src/winmain/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/winmain/CMakeLists.txt b/src/winmain/CMakeLists.txt
new file mode 100644
index 0000000000..fb48fec5a3
--- /dev/null
+++ b/src/winmain/CMakeLists.txt
@@ -0,0 +1,28 @@
+# special case begin
+# special case skip regeneration
+if (NOT WIN32)
+ return()
+endif()
+
+qt_add_module(WinMain
+ STATIC
+ NO_SYNC_QT
+ NO_MODULE_HEADERS
+ DEFINES
+ QT_NO_FOREACH
+ INCLUDE_DIRECTORIES
+ $<TARGET_PROPERTY:Qt::Core,INTERFACE_INCLUDE_DIRECTORIES>
+)
+
+qt_extend_target(WinMain CONDITION WINRT
+ SOURCES qtmain_winrt.cpp
+)
+
+qt_extend_target(WinMain CONDITION NOT WINRT
+ SOURCES qtmain_win.cpp
+)
+
+qt_extend_target(WinMain CONDITION MINGW
+ DEFINES QT_NEEDS_QMAIN
+)
+# special case end