summaryrefslogtreecommitdiffstats
path: root/src/xml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/xml/CMakeLists.txt')
-rw-r--r--src/xml/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/xml/CMakeLists.txt b/src/xml/CMakeLists.txt
new file mode 100644
index 0000000000..9a9d431072
--- /dev/null
+++ b/src/xml/CMakeLists.txt
@@ -0,0 +1,34 @@
+# Generated from xml.pro.
+
+#####################################################################
+## Xml Module:
+#####################################################################
+
+add_qt_module(Xml
+ SOURCES
+ dom/qdom.cpp dom/qdom.h
+ qtxmlglobal.h
+ sax/qxml.cpp sax/qxml.h sax/qxml_p.h
+ DEFINES
+ QT_NO_FOREACH
+ QT_NO_USING_NAMESPACE
+ LIBRARIES
+ Qt::CorePrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+)
+
+#### Keys ignored in scope 1:.:.:xml.pro:<TRUE>:
+# _LOADED = "qt_module"
+
+## Scopes:
+#####################################################################
+
+extend_target(Xml CONDITION MSVC AND (TEST_architecture_arch STREQUAL "i386")
+ LINK_OPTIONS
+ "/BASE:0x61000000"
+)
+add_qt_docs(Xml
+ doc/qtxml.qdocconf
+)
+