summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 0000000000..159554e4a9
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,15 @@
+# special case begin
+if(NOT TARGET Qt::Test)
+ cmake_minimum_required(VERSION 3.14.0)
+ project(QtBaseTests C CXX ASM)
+ find_package(Qt6 REQUIRED COMPONENTS BuildInternals Core Test)
+ find_package(Qt6 COMPONENTS DBus Gui OpenGL Widgets Xml)
+ qt_set_up_standalone_tests_build()
+
+ # Find a few packages that are usually found in configure.cmake,
+ # because a few tests link directly against those libraries.
+ qt_find_package(WrapDBus1 PROVIDED_TARGETS dbus-1)
+endif()
+# special case end
+
+qt_build_tests()