summaryrefslogtreecommitdiffstats
path: root/tests/auto/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/CMakeLists.txt')
-rw-r--r--tests/auto/CMakeLists.txt55
1 files changed, 55 insertions, 0 deletions
diff --git a/tests/auto/CMakeLists.txt b/tests/auto/CMakeLists.txt
new file mode 100644
index 0000000000..5ee23c0023
--- /dev/null
+++ b/tests/auto/CMakeLists.txt
@@ -0,0 +1,55 @@
+# Generated from auto.pro.
+
+if (NOT APPLE_UIKIT)
+ add_subdirectory("corelib")
+endif()
+if (QT_FEATURE_dbus)
+ set(run_dbus_tests ON)
+ if(NOT CMAKE_CROSSCOMPILING AND TARGET Qt::DBus)
+ execute_process(COMMAND dbus-send --session --type=signal / local.AutotestCheck.Hello
+ RESULT_VARIABLE dbus_session_test
+ OUTPUT_QUIET ERROR_QUIET)
+ if(NOT "${dbus_session_test}" STREQUAL "0")
+ set(run_dbus_tests OFF)
+ if(QT_FEATURE_dbus_linked)
+ message(SEND_ERROR "QtDBus is enabled but session bus is not available for testing. Please check the installation.")
+ else()
+ message(WARNING "QtDBus is enabled with runtime support, but session bus is not available. Skipping QtDBus tests.")
+ endif()
+ endif()
+ endif()
+ if(run_dbus_tests)
+ add_subdirectory("dbus")
+ endif()
+endif()
+if (NOT APPLE_UIKIT AND QT_FEATURE_gui)
+ add_subdirectory("gui")
+endif()
+if (QT_FEATURE_network AND NOT WINRT)
+# add_subdirectory("network")
+endif()
+if (TARGET Qt::OpenGL AND NOT WINRT)
+ add_subdirectory("opengl")
+endif()
+if (QT_FEATURE_sql)
+# add_subdirectory("sql")
+endif()
+add_subdirectory("testlib")
+if (NOT CMAKE_CROSSCOMPILE AND QT_FEATURE_process)
+# add_subdirectory("tools")
+endif()
+if (QT_FEATURE_xml)
+# add_subdirectory("xml")
+endif()
+if (QT_FEATURE_concurrent)
+# add_subdirectory("concurrent")
+endif()
+# add_subdirectory("other")
+if (QT_FEATURE_widgets)
+ add_subdirectory("widgets")
+endif()
+if (QT_FEATURE_printsupport)
+# add_subdirectory("printsupport")
+endif()
+# add_subdirectory("cmake") ## FIXME: Does this still make sense in this form?
+# add_subdirectory("installed_cmake") ## FIXME: Does this still make sense in this form?