summaryrefslogtreecommitdiffstats
path: root/tests/auto/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/CMakeLists.txt')
-rw-r--r--tests/auto/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/tests/auto/CMakeLists.txt b/tests/auto/CMakeLists.txt
index 5ee23c0023..13728bd49b 100644
--- a/tests/auto/CMakeLists.txt
+++ b/tests/auto/CMakeLists.txt
@@ -22,11 +22,11 @@ if (QT_FEATURE_dbus)
add_subdirectory("dbus")
endif()
endif()
-if (NOT APPLE_UIKIT AND QT_FEATURE_gui)
+if (NOT APPLE_UIKIT AND TARGET Qt::Gui)
add_subdirectory("gui")
endif()
-if (QT_FEATURE_network AND NOT WINRT)
-# add_subdirectory("network")
+if (TARGET Qt::Network AND NOT WINRT)
+ # add_subdirectory("network")
endif()
if (TARGET Qt::OpenGL AND NOT WINRT)
add_subdirectory("opengl")
@@ -38,17 +38,17 @@ add_subdirectory("testlib")
if (NOT CMAKE_CROSSCOMPILE AND QT_FEATURE_process)
# add_subdirectory("tools")
endif()
-if (QT_FEATURE_xml)
+if (TARGET Qt::Xml)
# add_subdirectory("xml")
endif()
-if (QT_FEATURE_concurrent)
+if (TARGET Qt::Concurrent)
# add_subdirectory("concurrent")
endif()
# add_subdirectory("other")
-if (QT_FEATURE_widgets)
+if (TARGET Qt::Widgets)
add_subdirectory("widgets")
endif()
-if (QT_FEATURE_printsupport)
+if (TARGET Qt::PrintSupport)
# add_subdirectory("printsupport")
endif()
# add_subdirectory("cmake") ## FIXME: Does this still make sense in this form?