summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/cmake/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/CMakeLists.txt12
1 files changed, 8 insertions, 4 deletions
diff --git a/tests/auto/cmake/CMakeLists.txt b/tests/auto/cmake/CMakeLists.txt
index 8852c7e68b..eb23e66fe8 100644
--- a/tests/auto/cmake/CMakeLists.txt
+++ b/tests/auto/cmake/CMakeLists.txt
@@ -125,10 +125,14 @@ if (CMAKE_GENERATOR STREQUAL Ninja AND UNIX AND NOT WIN32)
BINARY "tests/test_QFINDTESTDATA"
SIMULATE_IN_SOURCE
)
- _qt_internal_test_expect_pass(test_QT_TESTCASE_BUILDDIR
- BINARY "test_qt_testcase_builddir"
- SIMULATE_IN_SOURCE
- )
+ # TODO: Decide if there's a reason to keep this test. With CMake 3.21.0 which passes absolute
+ # source file paths to the compiler (instead of relative ones), specifying a custom
+ # QT_TESTCASE_BUILDDIR is a no-op, which fails the test's preconditions.
+ # See QTBUG-95268.
+ #_qt_internal_test_expect_pass(test_QT_TESTCASE_BUILDDIR
+ # BINARY "test_qt_testcase_builddir"
+ # SIMULATE_IN_SOURCE
+ #)
endif()
if (NOT NO_DBUS)