summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/cmake/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/auto/cmake/CMakeLists.txt b/tests/auto/cmake/CMakeLists.txt
index 1abbef0d68..c780096854 100644
--- a/tests/auto/cmake/CMakeLists.txt
+++ b/tests/auto/cmake/CMakeLists.txt
@@ -116,13 +116,18 @@ endif()
set(qt_module_includes
Core QObject
- Gui QImage
Network QHostInfo
Sql QSqlError
Test QTestEventList
Xml QDomDocument
)
+if (NOT NO_GUI)
+ list(APPEND qt_module_includes
+ Gui QImage
+ )
+endif()
+
if (NOT NO_WIDGETS)
list(APPEND qt_module_includes
Widgets QWidget