summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/mockplugins/mock4plugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/cmake/mockplugins/mock4plugin/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/mockplugins/mock4plugin/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/auto/cmake/mockplugins/mock4plugin/CMakeLists.txt b/tests/auto/cmake/mockplugins/mock4plugin/CMakeLists.txt
new file mode 100644
index 0000000000..f254f044d5
--- /dev/null
+++ b/tests/auto/cmake/mockplugins/mock4plugin/CMakeLists.txt
@@ -0,0 +1,10 @@
+qt_internal_add_plugin(QMock4Plugin
+ CLASS_NAME QMock4Plugin
+ TYPE mockplugin
+ DEFAULT_IF FALSE
+ SOURCES
+ qmock4plugin.cpp qmock4plugin.h
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::MockPlugins1
+)