summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/test_generating_cpp_exports/test_autogenerating_cpp_exports_custom_name/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/cmake/test_generating_cpp_exports/test_autogenerating_cpp_exports_custom_name/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/test_generating_cpp_exports/test_autogenerating_cpp_exports_custom_name/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/tests/auto/cmake/test_generating_cpp_exports/test_autogenerating_cpp_exports_custom_name/CMakeLists.txt b/tests/auto/cmake/test_generating_cpp_exports/test_autogenerating_cpp_exports_custom_name/CMakeLists.txt
new file mode 100644
index 0000000000..8473979c70
--- /dev/null
+++ b/tests/auto/cmake/test_generating_cpp_exports/test_autogenerating_cpp_exports_custom_name/CMakeLists.txt
@@ -0,0 +1,24 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+qt_internal_add_module(TestAutogeneratingCppExportsCustomName
+ NO_UNITY_BUILD
+ GENERATE_CPP_EXPORTS
+ CPP_EXPORT_HEADER_BASE_NAME
+ "customname_exports"
+ SOURCES
+ module_api.h
+ module_api.cpp
+ PUBLIC_LIBRARIES
+ Qt::Core
+)
+
+qt_internal_extend_target(TestAutogeneratingCppExportsCustomName
+ CONDITION GCC OR MINGW
+ COMPILE_OPTIONS
+ -fvisibility=hidden
+)
+
+add_executable(testapp2 use_api.cpp)
+target_link_libraries(testapp2 PRIVATE TestAutogeneratingCppExportsCustomName)
+set_target_properties(testapp2 PROPERTIES UNITY_BUILD OFF)