summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/tst_qaddpreroutine/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/cmake/tst_qaddpreroutine/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/tst_qaddpreroutine/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/tests/auto/cmake/tst_qaddpreroutine/CMakeLists.txt b/tests/auto/cmake/tst_qaddpreroutine/CMakeLists.txt
index 624a1214c8..bc1a6339db 100644
--- a/tests/auto/cmake/tst_qaddpreroutine/CMakeLists.txt
+++ b/tests/auto/cmake/tst_qaddpreroutine/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
#####################################################################
## tst_qaddpreroutine Test:
#####################################################################
@@ -22,6 +25,7 @@ qt_prepare_standalone_project()
find_package(Qt6 COMPONENTS Gui Test CONFIG REQUIRED)
qt_internal_add_plugin(QTBUG_90341ThemePlugin
+ NO_UNITY_BUILD
OUTPUT_NAME QTBUG_90341
OUTPUT_DIRECTORY "${CMAKE_BINARY_DIR}"
CLASS_NAME ThemePlugin
@@ -30,7 +34,7 @@ qt_internal_add_plugin(QTBUG_90341ThemePlugin
SOURCES
plugin.cpp
SKIP_INSTALL
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Core
Qt::Gui
Qt::GuiPrivate
@@ -39,7 +43,7 @@ qt_internal_add_plugin(QTBUG_90341ThemePlugin
qt_internal_add_test(tst_qaddpreroutine
SOURCES
tst_qaddpreroutine.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Gui
)