summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/global/qnativeinterface/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/global/qnativeinterface/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/global/qnativeinterface/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/tests/auto/corelib/global/qnativeinterface/CMakeLists.txt b/tests/auto/corelib/global/qnativeinterface/CMakeLists.txt
new file mode 100644
index 0000000000..2c87e07b21
--- /dev/null
+++ b/tests/auto/corelib/global/qnativeinterface/CMakeLists.txt
@@ -0,0 +1,15 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qnativeinterface LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_qnativeinterface
+ SOURCES
+ tst_qnativeinterface.cpp
+ LIBRARIES
+ Qt::CorePrivate
+)