summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/global/qxp/function_ref/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/global/qxp/function_ref/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/global/qxp/function_ref/CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/tests/auto/corelib/global/qxp/function_ref/CMakeLists.txt b/tests/auto/corelib/global/qxp/function_ref/CMakeLists.txt
index 91c797c32f..351fe24b22 100644
--- a/tests/auto/corelib/global/qxp/function_ref/CMakeLists.txt
+++ b/tests/auto/corelib/global/qxp/function_ref/CMakeLists.txt
@@ -1,7 +1,16 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qxp_function_ref LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qxp_function_ref
EXCEPTIONS
SOURCES
tst_qxp_function_ref.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Core
)