summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/auto/corelib/io/CMakeLists.txt b/tests/auto/corelib/io/CMakeLists.txt
index 18fc2bf375..cf014b2b1f 100644
--- a/tests/auto/corelib/io/CMakeLists.txt
+++ b/tests/auto/corelib/io/CMakeLists.txt
@@ -41,7 +41,12 @@ if(TARGET Qt::Network)
add_subdirectory(qiodevice)
endif()
if(QT_FEATURE_process AND TARGET Qt::Network AND NOT ANDROID)
- add_subdirectory(qprocess)
+ # special case begin
+ # QTBUG-85287: Hangs on qemu armv7 config
+ if(NOT CMAKE_CROSSCOMPILING)
+ add_subdirectory(qprocess)
+ endif()
+ # special case end
endif()
if(QT_FEATURE_process)
add_subdirectory(qprocess-noapplication)