summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/largefile/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/largefile/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/largefile/CMakeLists.txt16
1 files changed, 11 insertions, 5 deletions
diff --git a/tests/auto/corelib/io/largefile/CMakeLists.txt b/tests/auto/corelib/io/largefile/CMakeLists.txt
index 6e9a3cbae8..17b411ab33 100644
--- a/tests/auto/corelib/io/largefile/CMakeLists.txt
+++ b/tests/auto/corelib/io/largefile/CMakeLists.txt
@@ -1,13 +1,19 @@
-# Generated from largefile.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_largefile Test:
#####################################################################
-qt_add_test(tst_largefile
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_largefile LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_largefile
SOURCES
- ../../../../shared/emulationdetector.h
tst_largefile.cpp
- INCLUDE_DIRECTORIES
- ../../../../shared
+ LIBRARIES
+ Qt::TestPrivate
)