summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qdebug/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qdebug/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qdebug/CMakeLists.txt14
1 files changed, 11 insertions, 3 deletions
diff --git a/tests/auto/corelib/io/qdebug/CMakeLists.txt b/tests/auto/corelib/io/qdebug/CMakeLists.txt
index 067e3be04b..89d39c4375 100644
--- a/tests/auto/corelib/io/qdebug/CMakeLists.txt
+++ b/tests/auto/corelib/io/qdebug/CMakeLists.txt
@@ -1,16 +1,24 @@
-# Generated from qdebug.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qdebug Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qdebug LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qdebug
SOURCES
tst_qdebug.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Concurrent
)
if (APPLE)
- target_compile_options(tst_qdebug PRIVATE -x objective-c++)
+ enable_language(OBJCXX)
+ set_source_files_properties(tst_qdebug.cpp PROPERTIES LANGUAGE OBJCXX)
endif()