summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qfileinfo/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qfileinfo/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qfileinfo/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/tests/auto/corelib/io/qfileinfo/CMakeLists.txt b/tests/auto/corelib/io/qfileinfo/CMakeLists.txt
new file mode 100644
index 0000000000..58ef56d31e
--- /dev/null
+++ b/tests/auto/corelib/io/qfileinfo/CMakeLists.txt
@@ -0,0 +1,34 @@
+# Generated from qfileinfo.pro.
+
+#####################################################################
+## tst_qfileinfo Test:
+#####################################################################
+
+add_qt_test(tst_qfileinfo
+ SOURCES
+ tst_qfileinfo.cpp
+ LIBRARIES
+ Qt::CorePrivate
+)
+
+# Resources:
+add_qt_resource(tst_qfileinfo "qfileinfo" PREFIX "/tst_qfileinfo/" FILES
+ resources/)
+add_qt_resource(tst_qfileinfo "testdata" PREFIX "/testdata" FILES
+ resources/file1
+ resources/file1.ext1
+ resources/file1.ext1.ext2
+ tst_qfileinfo.cpp)
+
+
+#### Keys ignored in scope 1:.:.:qfileinfo.pro:<TRUE>:
+# CONFIG = "testcase"
+
+## Scopes:
+#####################################################################
+
+extend_target(tst_qfileinfo CONDITION WIN32 AND NOT WINRT
+ PUBLIC_LIBRARIES
+ advapi32
+ netapi32
+)