summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qlockfile/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qlockfile/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qlockfile/CMakeLists.txt21
1 files changed, 16 insertions, 5 deletions
diff --git a/tests/auto/corelib/io/qlockfile/CMakeLists.txt b/tests/auto/corelib/io/qlockfile/CMakeLists.txt
index baab320b8c..1dda272d52 100644
--- a/tests/auto/corelib/io/qlockfile/CMakeLists.txt
+++ b/tests/auto/corelib/io/qlockfile/CMakeLists.txt
@@ -1,13 +1,20 @@
-# Generated from qlockfile.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qlockfile Test:
#####################################################################
-qt_add_test(tst_qlockfile
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qlockfile LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_qlockfile
SOURCES
tst_qlockfile.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Concurrent
Qt::CorePrivate
)
@@ -15,8 +22,12 @@ qt_add_test(tst_qlockfile
## Scopes:
#####################################################################
-qt_extend_target(tst_qlockfile CONDITION WIN32
- PUBLIC_LIBRARIES
+qt_internal_extend_target(tst_qlockfile CONDITION WIN32
+ LIBRARIES
advapi32
)
add_subdirectory(qlockfiletesthelper)
+
+if(QT_FEATURE_process AND NOT ANDROID)
+ add_dependencies(tst_qlockfile qlockfile_test_helper)
+endif()