summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qlockfile/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qlockfile/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qlockfile/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/tests/auto/corelib/io/qlockfile/CMakeLists.txt b/tests/auto/corelib/io/qlockfile/CMakeLists.txt
index 456ee88bb0..1dda272d52 100644
--- a/tests/auto/corelib/io/qlockfile/CMakeLists.txt
+++ b/tests/auto/corelib/io/qlockfile/CMakeLists.txt
@@ -1,11 +1,20 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
#####################################################################
## tst_qlockfile Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qlockfile LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qlockfile
SOURCES
tst_qlockfile.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Concurrent
Qt::CorePrivate
)
@@ -14,7 +23,7 @@ qt_internal_add_test(tst_qlockfile
#####################################################################
qt_internal_extend_target(tst_qlockfile CONDITION WIN32
- PUBLIC_LIBRARIES
+ LIBRARIES
advapi32
)
add_subdirectory(qlockfiletesthelper)