summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qlockfile/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qlockfile/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qlockfile/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/tests/auto/corelib/io/qlockfile/CMakeLists.txt b/tests/auto/corelib/io/qlockfile/CMakeLists.txt
new file mode 100644
index 0000000000..52bd7bfd8f
--- /dev/null
+++ b/tests/auto/corelib/io/qlockfile/CMakeLists.txt
@@ -0,0 +1,23 @@
+# Generated from qlockfile.pro.
+
+#####################################################################
+## tst_qlockfile Test:
+#####################################################################
+
+add_qt_test(tst_qlockfile
+ SOURCES
+ tst_qlockfile.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ PUBLIC_LIBRARIES
+ Qt::Concurrent
+)
+
+## Scopes:
+#####################################################################
+
+extend_target(tst_qlockfile CONDITION WIN32 AND NOT WINRT
+ PUBLIC_LIBRARIES
+ advapi32
+)
+add_subdirectory(qlockfiletesthelper)