summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qprocess/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qprocess/test/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qprocess/test/CMakeLists.txt11
1 files changed, 8 insertions, 3 deletions
diff --git a/tests/auto/corelib/io/qprocess/test/CMakeLists.txt b/tests/auto/corelib/io/qprocess/test/CMakeLists.txt
index 9cd8fee6e8..89893583ac 100644
--- a/tests/auto/corelib/io/qprocess/test/CMakeLists.txt
+++ b/tests/auto/corelib/io/qprocess/test/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
#####################################################################
## tst_qprocess Test:
#####################################################################
@@ -6,9 +9,10 @@ qt_internal_add_test(tst_qprocess
OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../"
SOURCES
../tst_qprocess.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::CorePrivate
Qt::Network
+ Qt::TestPrivate
)
## Build assorted sub-programs called from the test:
@@ -39,5 +43,6 @@ if(WIN32)
add_dependencies(tst_qprocess testProcessEchoGui testSetNamedPipeHandleState)
endif()
-#### Keys ignored in scope 2:.:.:test.pro:WIN32:
-# TESTDATA = "../testBatFiles/*"
+if(UNIX)
+ add_dependencies(tst_qprocess testUnixProcessParameters)
+endif()