summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qprocess/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qprocess/test/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qprocess/test/CMakeLists.txt46
1 files changed, 34 insertions, 12 deletions
diff --git a/tests/auto/corelib/io/qprocess/test/CMakeLists.txt b/tests/auto/corelib/io/qprocess/test/CMakeLists.txt
index 086a5663e8..89893583ac 100644
--- a/tests/auto/corelib/io/qprocess/test/CMakeLists.txt
+++ b/tests/auto/corelib/io/qprocess/test/CMakeLists.txt
@@ -1,4 +1,5 @@
-# Generated from test.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qprocess Test:
@@ -8,19 +9,40 @@ qt_internal_add_test(tst_qprocess
OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../"
SOURCES
../tst_qprocess.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::CorePrivate
Qt::Network
+ Qt::TestPrivate
)
-#### Keys ignored in scope 1:.:.:test.pro:<TRUE>:
-# TEST_HELPER_INSTALLS = "../testProcessSpacesArgs/nospace" "../testProcessSpacesArgs/one space" "../testProcessSpacesArgs/two space s" "../test Space In Name/testSpaceInName"
-
-## Scopes:
-#####################################################################
-
-#### Keys ignored in scope 2:.:.:test.pro:WIN32:
-# TESTDATA = "../testBatFiles/*"
+## Build assorted sub-programs called from the test:
+add_dependencies(tst_qprocess
+ testProcessCrash
+ testProcessEcho
+ testProcessEcho2
+ testProcessEcho3
+ testProcessEnvironment
+ testProcessHang
+ testProcessNormal
+ testProcessOutput
+ testProcessDeadWhileReading
+ testProcessEOF
+ testExitCodes
+ testForwarding
+ testDetached
+ fileWriterProcess
+ testSetWorkingDirectory
+ testSoftExit
+ nospace onespace twospaces
+ testSpaceInName
+)
+if(TARGET Qt::Widgets)
+ add_dependencies(tst_qprocess testGuiProcess)
+endif()
+if(WIN32)
+ add_dependencies(tst_qprocess testProcessEchoGui testSetNamedPipeHandleState)
+endif()
-#### Keys ignored in scope 5:.:..:../qprocess.pri:NOT TARGET Qt::Widgets:
-# SUBPROGRAMS = "-testGuiProcess"
+if(UNIX)
+ add_dependencies(tst_qprocess testUnixProcessParameters)
+endif()