summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qprocess/testSoftExit/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qprocess/testSoftExit/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qprocess/testSoftExit/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/tests/auto/corelib/io/qprocess/testSoftExit/CMakeLists.txt b/tests/auto/corelib/io/qprocess/testSoftExit/CMakeLists.txt
index f6088e1032..44099dcab1 100644
--- a/tests/auto/corelib/io/qprocess/testSoftExit/CMakeLists.txt
+++ b/tests/auto/corelib/io/qprocess/testSoftExit/CMakeLists.txt
@@ -1,13 +1,19 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
#####################################################################
## testSoftExit Binary:
#####################################################################
-add_executable(testSoftExit)
+qt_internal_add_executable(testSoftExit
+ OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/"
+ CORE_LIBRARY None
+)
qt_internal_extend_target(testSoftExit CONDITION WIN32
SOURCES
main_win.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
user32
)